Jump to content
Cesbo Community
  • Announcements

    • RadioSintetica

      Information   10/21/18

      Registration on the forum temporarily closed! For support requests, please contacat us: https://cesbo.com/help
      Our community in Telegram: @cesbo_en (English language) , @cesbo_ru (Russian language) , @cesbo_es (Spanish Language)

stefki

Members
  • Content count

    47
  • Joined

  • Last visited

  • Days Won

    1

stefki last won the day on April 6 2016

stefki had the most liked content!

About stefki

  • Rank
    Member
  • Birthday 05/11/87
  1. Any news on this issue?
  2. Sorry I can't speak russian language. Anyone could help ?
  3. Hello all, I have two of these v6.1 DVB-C/T cards installed on my Ubuntu 14.04 server . The cards works very stable with Astra 5.64. But Linux and Astra don't show the signal bars. Which is very annoying , I have compiled the drivers from here https://github.com/DigitalDevices/dddvb/releases I think is driver related problem. No signal stats at all. I am not experienced in C language code. Can someone experienced user please send me a patch to add and compile the code to my drivers ? root@hermes:~# dmesg | grep -i dvb[ 17.837765] dvb_core: module verification failed: signature and/or required key missing - tainting kernel[ 17.875602] ddbridge 0000:02:00.0: device name: Digital Devices DVBCT V6.1 DVB adapter [ 17.879278] ddbridge 0000:02:00.0: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-C/T [ 17.887269] dvbdev: DVB: registering new adapter (DDBridge)[ 17.887271] dvbdev: DVB: registering new adapter (DDBridge)[ 19.416155] ddbridge 0000:02:00.0: DVB: registering adapter 0 frontend 0 (STV0367 DVB-C DVB-T)... [ 20.404392] ddbridge 0000:02:00.0: DVB: registering adapter 1 frontend 0 (STV0367 DVB-C DVB-T)...[ 20.404902] ddbridge 0000:03:00.0: device name: Digital Devices DVBCT V6.1 DVB adapter[ 20.407493] ddbridge 0000:03:00.0: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-C/T[ 20.411563] dvbdev: DVB: registering new adapter (DDBridge)[ 20.411565] dvbdev: DVB: registering new adapter (DDBridge)[ 21.048887] ddbridge 0000:03:00.0: DVB: registering adapter 2 frontend 0 (STV0367 DVB-C DVB-T)...[ 21.573273] ddbridge 0000:03:00.0: DVB: registering adapter 3 frontend 0 (STV0367 DVB-C DVB-T)...[ 124.832411] dvb_net: created network interface dvb3_0
  4. Can you please fix signal ratio on this card STV0367 DVB-C DVB-T Signal ratio is not detected on DD Cine v6 C&T card. Now I am using Ubuntu 14.04.5 LTS 3.13.0-117-generic Drivers taken from here git clone https://github.com/crazycat69/dddvb.git dmesg | grep frontend [ 9.828942] ddbridge 0000:1a:00.0: DVB: registering adapter 0 frontend 0 (STV0367 DVB-C DVB-T)... [ 10.375770] ddbridge 0000:1a:00.0: DVB: registering adapter 1 frontend 0 (STV0367 DVB-C DVB-T)... [ 10.670668] ddbridge 0000:1f:00.0: DVB: registering adapter 2 frontend 0 (STV090x Multistandard)... [ 10.707609] ddbridge 0000:1f:00.0: DVB: registering adapter 3 frontend 0 (STV090x Multistandard)... [ 11.027740] ddbridge 0000:24:00.0: DVB: registering adapter 4 frontend 0 (STV0910)... [ 11.031842] ddbridge 0000:24:00.0: DVB: registering adapter 5 frontend 0 (STV0910)... Also I detect strange error in dmseg log dmesg |grep dvb [ 8.906161] dvb_core: module verification failed: signature and/or required key missing - tainting kernel dmesg |grep error [ 0.956938] ioapic: probe of 0000:00:15.0 failed with error -22 [ 10.109030] tda18212dd: i2c_read error [ 11.020802] lnbh25: i2c_write error [ 11.028597] lnbh25: i2c_write error root@:~# dmesg |grep DDBridge [ 8.989466] DDBridge: Digital Devices PCIE bridge driver 0.9.28, Copyright © 2010-16 Digital Devices GmbH [ 8.989959] DDBridge: device name: Digital Devices DVBCT V6.1 DVB adapter [ 8.989985] DDBridge: HW 0001000d REGMAP 00010004 [ 8.990005] DDBridge: link 0 vendor dd01 device 0003 subvendor dd01 subdevice 0030 [ 8.992135] DDBridge: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-C/T [ 8.993140] DDBridge: Port 1: Link 0, Link Port 1 (TAB 2): NO MODULE [ 8.993213] DDBridge: Port 2: Link 0, Link Port 2 (TAB 3): NO MODULE [ 8.993671] DDBridge: 0 netstream channels [ 8.993673] DVB: registering new adapter (DDBridge) [ 8.993675] DVB: registering new adapter (DDBridge) [ 10.376173] DDBridge: device name: Digital Devices Cine S2 V6 DVB adapter [ 10.376214] DDBridge: HW 0001000d REGMAP 00010004 [ 10.376235] DDBridge: link 0 vendor dd01 device 0003 subvendor dd01 subdevice 0020 [ 10.377594] DDBridge: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-S2 [ 10.378724] DDBridge: Port 1: Link 0, Link Port 1 (TAB 2): NO MODULE [ 10.379824] DDBridge: Port 2: Link 0, Link Port 2 (TAB 3): NO MODULE [ 10.380238] DDBridge: 0 netstream channels [ 10.380241] DVB: registering new adapter (DDBridge) [ 10.380243] DVB: registering new adapter (DDBridge) [ 10.670506] DDBridge: attach tuner input 0 adr 60 [ 10.707365] DDBridge: attach tuner input 1 adr 63 [ 10.708034] DDBridge: device name: Digital Devices Octopus CI S2 Pro [ 10.708061] DDBridge: HW 00010002 REGMAP 00010005 [ 10.708081] DDBridge: link 0 vendor dd01 device 0013 subvendor dd01 subdevice 0043 [ 10.818530] DDBridge: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-S2 [ 10.818535] DDBridge: Port 1: Link 0, Link Port 1 (TAB 2): NO TAB [ 10.818538] DDBridge: Port 2: Link 0, Link Port 2 (TAB 3): CI internal [ 10.818541] DDBridge: Port 3: Link 0, Link Port 3 (TAB 4): CI internal [ 10.819790] DDBridge: 0 netstream channels [ 10.819794] DVB: registering new adapter (DDBridge) [ 10.819795] DVB: registering new adapter (DDBridge) [ 10.819796] DVB: registering new adapter (DDBridge) [ 10.819798] DVB: registering new adapter (DDBridge)
  5. Yesterday I bought these two cards TBS devices TBS-6290 SE and TBS-6910. Both cards are on the same server with Octopus CI S2 Pro Twin. But the cards are not detected. info CentOS Linux release 7.3.1611 (Core) uname -r 3.10.0-514.10.2.el7.x86_64 Drivers installed by this way rm -rf /lib/modules/${version}/kernel/drivers/media then 1. tar jxvf linux-tbs-drivers_xxx.tar.bz2 2. cd linux-tbs-drivers 3 ./v4l/tbs-x86_64.sh 4 ./v4l/tbs-dvbc-x86_64.sh 5. make 6, make install 7. reboot dmesg log [root@~]# dmesg | grep frontend [ 9.231443] tbs_pcie_dvb: disagrees about version of symbol dvb_frontend_detach [ 9.231444] tbs_pcie_dvb: Unknown symbol dvb_frontend_detach (err -22) [ 9.231455] tbs_pcie_dvb: disagrees about version of symbol dvb_unregister_frontend [ 9.231456] tbs_pcie_dvb: Unknown symbol dvb_unregister_frontend (err -22) [ 9.231465] tbs_pcie_dvb: disagrees about version of symbol dvb_register_frontend [ 9.231466] tbs_pcie_dvb: Unknown symbol dvb_register_frontend (err -22) [ 9.231806] tbs_pcie_dvb: disagrees about version of symbol dvb_frontend_detach [ 9.231808] tbs_pcie_dvb: Unknown symbol dvb_frontend_detach (err -22) [ 9.231822] tbs_pcie_dvb: disagrees about version of symbol dvb_unregister_frontend [ 9.231823] tbs_pcie_dvb: Unknown symbol dvb_unregister_frontend (err -22) [ 9.231834] tbs_pcie_dvb: disagrees about version of symbol dvb_register_frontend [ 9.231836] tbs_pcie_dvb: Unknown symbol dvb_register_frontend (err -22) [ 9.682481] ddbridge 0000:24:00.0: DVB: registering adapter 0 frontend 0 (STV0910)... [ 9.685427] ddbridge 0000:24:00.0: DVB: registering adapter 1 frontend 0 (STV0910)... [root@~]# 1a:00.0 Multimedia controller: TBS Technologies DVB-S2 4 Tuner PCIe Card 1f:00.0 Multimedia controller: TBS Technologies DVB-S2 4 Tuner PCIe Card 24:00.0 Multimedia controller: Digital Devices GmbH Device 0013 if I remove ddbridge card, and recompile drivers then both TBS cards works ok. What can be the problem ?
  6. Транскодирование

    I am trying to send HTTP streams directly to VPS restream panel. But I am getting this log from udpxy . The streams are disconnecting on every 15 minutes. I don't know what can be the problem. I have 14 transcode streams from FFmpeg, all streams are connected for 15 minutes, after while they are keep reconnecting. I must do multicast to unicast stream over loopback because ffmpeg don't have http output. Please some of you experienced user maybe can help me :) . ifconfig lo multicast ip route add 224.0.0.0/4 dev lo src 127.0.0.1 ip route flush cache /usr/local/bin/udpxy -p 7560 -m lo -c 40 -l /home/udpxy.log sleep 5 astra -c /home/polaris -p 1616 --log /home/astra.log --no-stdout --daemon sleep 5 cd /root/bin/ #RTS1 nohup ./ffmpeg -i "udp://lo@127.0.0.1:1001" -crf 21 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f mpegts udp://224.0.0.1:1111?pkt_size=1316 2> /home/rts1.log & #RTS2 nohup ./ffmpeg -i "udp://lo@127.0.0.1:1002" -crf 21 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f mpegts udp://224.0.0.2:1112?pkt_size=1316 2> /home/rts2.log & #B92 nohup ./ffmpeg -i "udp://lo@127.0.0.1:1003" -crf 21 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f mpegts udp://224.0.0.3:1113?pkt_size=1316 2> /home/b92.log & sleep 5 #Prva nohup ./ffmpeg -i "udp://lo@127.0.0.1:1004" -crf 21 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f mpegts udp://224.0.0.4:1114?pkt_size=1316 2> /home/prva.log & and so on.... UDPXY log c(3901) write_buf: socket time-out on write2016-12-03 14:05:22.785365 CET c(3903) write_buf: socket time-out on write2016-12-03 14:05:23.091033 CET c(3906) write_buf: socket time-out on write2016-12-03 14:05:23.191175 CET c(3902) write_buf: socket time-out on write2016-12-03 14:05:29.815214 CET c(3905) write_buf: socket time-out on write2016-12-03 14:05:29.857172 CET c(3910) write_buf: socket time-out on write2016-12-03 14:05:29.925170 CET c(3904) write_buf: socket time-out on write2016-12-03 14:05:32.660654 CET S(3883) Added client: pid=[3961], maddr=[224.0.0.2], mport=[1112], saddr=[xxx.xxx.xx.xxx], sport=[38546] S(3883) Added client: pid=[3962], maddr=[224.0.0.3], mport=[1113], saddr=[xxx.xxx.xx.xxx], sport=[38547] S(3883) Added client: pid=[3963], maddr=[224.0.0.5], mport=[1115], saddr=[xxx.xxx.xx.xxx], sport=[38548] S(3883) Added client: pid=[3964], maddr=[224.0.0.7], mport=[1117], saddr=[xxx.xxx.xx.xxx], sport=[38549] S(3883) Added client: pid=[3965], maddr=[224.0.0.14], mport=[1124], saddr=[xxx.xxx.xx.xxx], sport=[38550] c(3964) write_buf: socket time-out on write2016-12-03 14:05:48.449173 CET c(3913) write_buf: socket time-out on write2016-12-03 14:05:49.000203 CET c(3907) write_buf: socket time-out on write2016-12-03 14:05:49.309644 CET c(3962) write_buf: socket time-out on write2016-12-03 14:05:49.918278 CET c(3900) write_buf: socket time-out on write2016-12-03 14:05:50.322289 CET c(3912) write_buf: socket time-out on write2016-12-03 14:05:50.593285 CET c(3963) write_buf: socket time-out on write2016-12-03 14:05:53.297277 CET c(3911) write_buf: socket time-out on write2016-12-03 14:05:53.502288 CET c(3965) write_buf: socket time-out on write2016-12-03 14:05:53.652258 CET c(3909) write_buf: socket time-out on write2016-12-03 14:05:54.385936 CET S(3883) Added client: pid=[3966], maddr=[224.0.0.3], mport=[1113], saddr=[xxx.xxx.xx.xxx], sport=[38553] c(3961) read_buf: socket time-out on read2016-12-03 14:05:55.853325 CET c(3961) read_data - EOF S(3883) Added client: pid=[3967], maddr=[224.0.0.5], mport=[1115], saddr=[xxx.xxx.xx.xxx], sport=[38554] S(3883) Added client: pid=[3968], maddr=[224.0.0.2], mport=[1112], saddr=[xxx.xxx.xx.xxx], sport=[38555] c(3908) read_buf: socket time-out on read2016-12-03 14:05:59.006403 CET c(3908) read_data - EOF c(3966) read_buf: socket time-out on read2016-12-03 14:05:59.386289 CET c(3966) read_data - EOF S(3883) Added client: pid=[3970], maddr=[224.0.0.7], mport=[1117], saddr=[xxx.xxx.xx.xxx], sport=[38556] Http links connected to VPS panel http://xxx.xxx.xx.xxx:7560/udp/224.0.0.1:1111 http://xxx.xxx.xx.xxx:7560/udp/224.0.0.2:1112 http://xxx.xxx.xx.xxx:7560/udp/224.0.0.4:1114 netstat -su IcmpMsg: InType0: 2056 InType3: 23939 OutType3: 23939 OutType8: 2073 Udp: 34496883 packets received 23939 packets to unknown port received. 151276 packet receive errors 35844159 packets sent 22104 receive buffer errors 0 send buffer errors UdpLite: IpExt: InNoRoutes: 1 InMcastPkts: 14621621 OutMcastPkts: 14621557 InBcastPkts: 3 InOctets: 46373717531 OutOctets: 61833440257 InMcastOctets: 17409938956 OutMcastOctets: 17409936908 InBcastOctets: 1017 InNoECTPkts: 44043594
  7. Транскодирование

    Now I have another strange problem , FFmpeg accepts only one rtp stream input. If I start two ffmpeg process with two streams I am getting error [udp @ 0x3490c60] bind failed: Address already in use rtp://lo@127.0.0.1:1002: Input/output error Stream 1 ffmpeg -i "rtp://lo@127.0.0.1:1001" -crf 21 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f rtp_mpegts rtp://224.3.2.3:1236?pkt_size=1316 Stream 2 ffmpeg -i "rtp://lo@127.0.0.1:1002" -crf 21 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f rtp_mpegts rtp://224.3.2.4:1237?pkt_size=1316 Config from astra { "name": "RTS 1", "output": [ "rtp://lo@127.0.0.1:1001" ], "type": "spts", "enable": true, "id": "a002", "input": [ "dvb://a001#pnr=461&cas&cam=a005" ] }, { "name": "RTS 2", "input": [ "dvb://a001#pnr=462&cas&cam=a005" ], "type": "spts", "enable": true, "id": "a003", "output": [ "rtp://lo@127.0.0.1:1002" ] With UDP protocol everything works ok. but with RTP I am getting bind failed: Address already in use.
  8. Транскодирование

    This command -filter_complex "[0:v][0:s:0]overlay[v];[v]scale=720:-1[y]" -map [y] -map 0:1 works fine, but I am losing the second subtitle , When I play the stream on VLC the subtitle is playing ok. But the second one is missing I can't select another subtitle. I want both subtitles to be available. The 0xb68 to be default one overlay. Stream #0:2[0xb67](bul): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006) Stream #0:3[0xb68](srp): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006) thank you.
  9. Транскодирование

    @montenis: Stream specifier ':s:1' in filtergraph description [0:v][0:s:1]overlay[vid] matches no streams. not working
  10. Транскодирование

    Hello, please help , how to add default subtitle when I am doing transcoding ? This is my stream info. Program 501 Stream #0:0[0x9b0]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p(tv, bt470bg), 720x576 [sAR 16:11 DAR 20:11], 25 fps, 50 tbr, 90k tbn, 50 tbc Stream #0:1[0x9b1](eng): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 128 kb/s Stream #0:2[0xb67](bul): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006) Stream #0:3[0xb68](srp): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006) When I play on VLC I have to select the subtitle manually, same on Enigma2 . Which command to use with FFmpeg to overlay the subtitle. Thank you.! This is my command ffmpeg -i "udp://lo@224.3.2.19:1440" -crf 22 -maxrate 1500k -bufsize 1835k -vf pp=fd -s 720x576 -pix_fmt yuv420p -c:v libx264 -profile:v "high" -r 25 -preset veryfast -g 25 -keyint_min 50 -x264opts "keyint=50:min-keyint=50:no-scenecut" -acodec libfdk_aac -ac 2 -ar 44100 -ab 128k -f mpegts udp://224.3.2.1:1234?pkt_size=1316
  11. Everything is working ok. But i dont want errors in dmesg.
  12. @CrazyCat, how to change the address ?
  13. @CrazyCat, revert back to CentOs 7 3.10.0-327.28.3.el7.x86_64 Now your signal ratio is fixed and works ok. But I notice strange error in dmesg dmesg |grep error [ 0.888857] ioapic: probe of 0000:00:15.0 failed with error -22 [ 7.851827] lnbh25: i2c_write error [ 7.937102] lnbh25: i2c_write error
  14. @CrazyCat Recently I have installed my server with CentOS 6.8 64 bit I tried to compile the driver but it fails on make command, also I tried your patched drivers but same compile error. kernel-headers-2.6.32-642.4.2.el6.x86_64 CC [M] /usr/src/dddvb-0.9.24/dvb- core/dvb_net.o /usr/src/dddvb-0.9.24/dvb-core/dvb_net.c: In function Б─≤wq_set_multicast_listБ─≥: /usr/src/dddvb-0.9.24/dvb-core/dvb_net.c:1166: warning: assignment from incompatible pointer type /usr/src/dddvb-0.9.24/dvb-core/dvb_net.c:1166: error: Б─≤struct netdev_hw_addrБ─≥ has no member named Б─≤nextБ─≥ make[3]: *** [/usr/src/dddvb-0.9.24/dvb-core/dvb_net.o] Error 1 make[2]: *** [/usr/src/dddvb-0.9.24/dvb-core] Error 2 make[1]: *** [_module_/usr/src/dddvb-0.9.24] Error 2 make[1]: Leaving directory `/usr/src/kernels/2.6.32-642.4.2.el6.x86_64' make: *** [all] Error 2
×